npm install ember-cli Dimensione massima dello stack di chiamate superata

Sto affrontando un problema simile trovato in questa domanda: Win 8.1, Vagrant, Chef, Ubuntu, Ember-cli, ember nuovo “npm ERR! Tar.unpack errore untar /home/vagrant/.npm/”

Sto cercando di aggiornare un vecchio progetto ember a 2.1 usando il nuovo ember-cli. Sto facendo funzionare il mio progetto su un server vagabondo.

Ho nodo (v.0.12.7), npm (3.3.10), bower (1.6.5) ed ember-cli -g (versione: 1.13.8, nodo: 0.12.7, npm: 2.13.4, os : linux x64) installato.

Tuttavia, ogni volta che eseguo “npm install –no-bin-links” sul progetto generato da ember init, ottengo il seguente errore:

51716 error tar.unpack untar error /home/vagrant/.npm/ember-cli/1.13.8/package.tgz 51717 verbose stack RangeError: Maximum call stack size exceeded 51717 verbose stack at Array.filter (native) 51717 verbose stack at /usr/lib/node_modules/npm/lib/install/actions.js:55:37 51717 verbose stack at Array.forEach (native) 51717 verbose stack at markAsFailed (/usr/lib/node_modules/npm/lib/install/actions.js:54:16) 51717 verbose stack at /usr/lib/node_modules/npm/lib/install/actions.js:57:7 51717 verbose stack at Array.forEach (native) 51717 verbose stack at markAsFailed (/usr/lib/node_modules/npm/lib/install/actions.js:54:16) 51717 verbose stack at /usr/lib/node_modules/npm/lib/install/actions.js:57:7 51717 verbose stack at Array.forEach (native) 51717 verbose stack at markAsFailed (/usr/lib/node_modules/npm/lib/install/actions.js:54:16) 51718 verbose cwd /at/Site/public/preview/EP 51719 error Linux 3.2.0-4-amd64 51720 error argv "node" "/usr/bin/npm" "i" 51721 error node v0.12.7 51722 error npm v3.3.10 51723 error Maximum call stack size exceeded 51724 error If you need help, you may report this error at: 51724 error  51725 verbose exit [ 1, true ] 

Questo è legato ai diversi numeri di versione di npm (globalmente e in ember-cli) o è qualcosa nella mia configurazione vagabonda? Questo problema non è causato dalla lunghezza del percorso di Windows, ho già controllato.

MODIFICARE

Ho provato ad installare i pacchetti npm separatamente invece che con “npm install –no-bin-links”. L’unico errore è “npm install –no-bin-links [email protected]”. Queste sono le dipendenze all’interno del mio package.json:

 "broccoli-asset-rev": "^2.1.2", "ember-cli": "1.13.8", "ember-cli-app-version": "0.5.0", "ember-cli-babel": "^5.1.3", "ember-cli-content-security-policy": "0.4.0", "ember-cli-dependency-checker": "^1.0.1", "ember-cli-htmlbars": "0.7.9", "ember-cli-htmlbars-inline-precompile": "^0.2.0", "ember-cli-ic-ajax": "0.2.1", "ember-cli-inject-live-reload": "^1.3.1", "ember-cli-qunit": "^1.0.0", "ember-cli-release": "0.2.3", "ember-cli-sri": "^1.0.3", "ember-cli-uglify": "^1.2.0", "ember-data": "1.13.8", "ember-disable-proxy-controllers": "^1.0.0", "ember-export-application-global": "^1.0.3" 

Grazie per il tuo tempo

Ho risolto il mio problema.

A quanto pare, il modo in cui My folder è stato montato nel mio vagabondo è stato così lento da interferire con l’installazione di npm. Nel mio file vagabondo la cartella è stata montata in questo modo:

 config.vm.synced_folder "../", "/at" 

L’ho sostituito con questo:

 config.vm.provision "shell", run: "always" do |s| s.inline = "sudo apt-get update sudo bash /vagrant/mountfolder.sh" end 

E accanto al mio file vagabondo ho inserito un file “mountfolder.sh”

 # replace your username and password with for example: user, ****. Replace YOURSHARENAME with the name of your windows share # mountpoint checks if share is already mounted, prevents warning when provisioning mountpoint -q /projects|| (mkdir /projects -p && apt-get -y install cifs-utils && mount -t cifs //192.168.255.1/YOURSHARENAME /projects --verbose -o 'user=dkdomain.intra\YOURUSERNAME,password=YOURPASSWORD,rw,uid=vagrant,gid=vagrant,file_mode=0777,dir_mode=0777') 

Dove sostituisci le capitali con le informazioni necessarie.